RubyMine: Updating to Rails 4

Recently I spent some time upgrading one of my rails projects from Rails3 to Rails4. Among other resources Episode #415 from RailsCasts helped tremendously. However one of the issues that were not covered was fixing some of the issues with RubyMine integrations, more specifically the “Rails 3.x launcher script was found instead of Rails 4.x one”.

The easiest way I’ve found to address the issue is simply create a new rails 4 project and copy the bin/ directory that is created into your upgraded rails project. This doesn’t seem to me to be the cleanest solution but it does appear to be effective. Upon closer examination of the scripts in bin/ none of them appear to be project or even version specific. There are three scripts that is created: bundle, rails and rake.

The same error is produced even when attempting to run Rails 3 projects. Due to the way the new bin/ scripts were made they are also compatible with Rails3 projects. Performing the same copy solution above to your Rails 3 project will get RubyMine working again for you.

3 thoughts on “RubyMine: Updating to Rails 4

Leave a Reply